Page 18 of 19 FirstFirst ... 8141516171819 LastLast
Results 511 to 540 of 557

Thread: SR20 KE30 corolla

  1. #511
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    So i have been doing a lot of reading of late about caltrac setup, it seems i have pretty much everything wrong with how the car is setup. The first thing to address is the lack of upwards travel in the front end. I have a total of 40mm worth the current setup, required amount is 125mm or 5 inches. So the current heavily modified struts are out, and i have 2 choices in the shed, some ae86/corona/celica struts not sure what they are off tbh. Or standard corolla struts with my current vt commo brakes on them. Initially was keen to keep the same brakes cos of bias and all that, but the available shocks for a ke30 strut is nil because they run a tiny shock tube size. So will have to use the corona types struts as 2 way adjustable shocks would be ideal for setup ability.
    Plenty else to sort as well but this is the first step.

    Turbo gasket was blown as the turbo had come loose and had a few bolts missing, couldn't see it cos of the heat sheild. Oil drain had a little weep too so good to find that as well.










    Found this pic in my photobucket, wish it was mine!

    Last edited by SR20 KE30; 09-06-17 at 06:04 PM.
    meh

  2. #512
    I need more cylinders! nine2nine's Avatar
    Join Date
    Dec 2007
    Location
    Gympie, QLD
    Posts
    1,877
    Get those angles sorted asap and get a decent number! I'll lend you my tyres for some electrical work.

    Projects:
    '90 2jz-gte 929
    '02 twin-locked TD42 GU Patrol

  3. #513
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    Deal! as if, just supply the beers. Text me a list of what we are doing and i will make sure we are not short of stuff. Maybe this weekend?

    Did the trek to the letter box was not disappointed, stuff is here, i got a permaseal gasket this time, a new drain flange with 10an inbuilt so it's one piece, and a 10an extender so i can get the drain off easily.




    Also looked at base timing today, using the dial gauge it appears to be spot on at tdc, im not 100% sure that's where it was when it was tuned, but can't blame that right now. So still looking for the missing ponies at this stage. It can only really be timing or compression because the car runs really nice.

    Will do some plug tuning at the track next time, but first i still need to sort this launch out.

  4. #514
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    Car is all back together, i have progressed with the new struts but they are not in the car yet.

    Good news this arvo, checked timing properly this time, was 9 degrees out on the base timing.

    Fixed it up and went a drive, was not mega impressed but then i remembered i had pulled a heap of boost out at the drags. Put 25psi back in and yep it seems back up where it should be, its always hard to tell by seat of the pants but the drag radials seem to be holding up about the right amount.

  5. #515
    I need more cylinders! nine2nine's Avatar
    Join Date
    Dec 2007
    Location
    Gympie, QLD
    Posts
    1,877
    Sweet. When we heading out next? I'm on holidays so let's go.

    Projects:
    '90 2jz-gte 929
    '02 twin-locked TD42 GU Patrol

  6. #516
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    Pretty soon i think. Finish new struts, wire up 2 step and should be good for another run. I need to adjust the catracs as well as it wants to go right a bit.

  7. #517
    Registered User 31wags's Avatar
    Join Date
    Sep 2010
    Location
    adelaide
    Posts
    165
    Awesome news.

  8. #518
    Barra Is Life. no13b_Coupe's Avatar
    Join Date
    Mar 2012
    Location
    Canberra Nth
    Posts
    2,722
    Quote Originally Posted by 31wags View Post
    Awesome news.
    x2 good luck man!
    BF XR6 Turbo - 2L Turbo TE - 75 TX Coupe

    - PSN: rotacoupe

    This is obviously assuming all your AUX outputs are doing something. Ie idle control, and the other does water spray, and the other updates your Instagram automatically etc.

  9. #519
    Registered User rash's Avatar
    Join Date
    Aug 2010
    Location
    South Yandina
    Posts
    142
    Awesome man, found the missing power!

  10. #520
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    Yep! im real happy, gonna be a bit more 1/4 mile comin up i think!

  11. #521
    Registered User rash's Avatar
    Join Date
    Aug 2010
    Location
    South Yandina
    Posts
    142
    Quote Originally Posted by SR20 KE30 View Post
    Yep! im real happy, gonna be a bit more 1/4 mile comin up i think!
    Yep, have to line up a certain 2J mazda... (nudge nudge nine2nine).

  12. #522
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    Rx7.......

  13. #523
    Registered User rash's Avatar
    Join Date
    Aug 2010
    Location
    South Yandina
    Posts
    142
    Quote Originally Posted by SR20 KE30 View Post
    Rx7.......
    Haha, point taken..

  14. #524
    caibstastic!!1 caibs's Avatar
    Join Date
    Oct 2003
    Location
    perth
    Posts
    228
    good work finding the power issue man. was it down across the board?

    Sent from my SM-G900I using Tapatalk
    some fucken busted ass peice of shit

  15. #525
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    Yep it was down all over, even the response off idle is so much better now, the fact that i didn't even realize until i hit the drags means i really need to drive it more often.

  16. #526
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    Today i finalised how the front struts are going to happen.
    ta22 front socks, std ke30 front springs.

    I'm using the struts in the car and extending them to suit the ta22 shocks, im going to use a top spring plate on the bottom of the spring as well and have run a holesaw through a pair so they fit over the struts.

    Had planned to do this this arvo, had the car up and wheels off, but realised i have no bump stops to slip over the shocks. So i ordered them, and put the car back down and went for a drive. Was awesome.
    meh

  17. #527
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    Cruised to a couple of car shows last weekend, it's been awhile so was really good to get out there.

    I've been planning to do the front struts for a bit, yesterday was that day. The plan was to use ta22 shocks, but they didn't end up fitting in the strut tubes so plan b was a pair of standard ke30 Monroe shocks. I still used the adjustable ride height threaded things, combined with a set of standard 1976 corolla springs.


  18. #528
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761

  19. #529
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761


    The result was better than i ever had hoped for, the car rides so much better, sits perfect height, it's just so much better to drive i wish i did this so many years ago! !

    The reason for this whole strut change though was to give the front a minimum of 5 inches of uptravel so that it hooks up better. Can confirm it worked a treat, can now drop 2nd on the highway at 100, the front lifts and it hooks hard!

    So happy with the result. have booked a test day at willowbank for next weekend, air will be cold and track will be sticky because of jambo lead-up.

  20. #530
    I need more cylinders! nine2nine's Avatar
    Join Date
    Dec 2007
    Location
    Gympie, QLD
    Posts
    1,877
    Sweet. So glad the struts have worked out. Let us know when you're going to Willow, see if I can make it.

    Projects:
    '90 2jz-gte 929
    '02 twin-locked TD42 GU Patrol

  21. #531
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    Sat 19th 2:30 start for test meet max 30 cars, then flows into a tnt.

  22. #532
    caibstastic!!1 caibs's Avatar
    Join Date
    Oct 2003
    Location
    perth
    Posts
    228
    how did you manage to use the coilover ride height adjustment with standard springs man? whats the complete strut and brake package if you dont mind me asking?

    Sent from my SM-G900I using Tapatalk
    some fucken busted ass peice of shit

  23. #533
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    My coilovers thing is a sleeve with 2 alloy nuts that just gets welded onto the strut. To adapt a standard spring we machined 3mm off the top nut but left the last 5mm closest to the tube so we created an edge to locate onto. We then machined a steel ring that locates on that step and welded it to the factory lower spring perch.

    When i redid it on Friday, instead of using the factory lower spring perches i holesawed a spare pair of top spring perches to sit upside down on that edge instead, because they are flat i was able to run the factory spring without chopping at all, and the car stayed low.

    If none of this makes sense i can try and get some pics that might help.

    My struts are ke30 with 300mm commodore rotors and calipers. The way the disk is adapted though i couldnt recommend so not much help.

  24. #534
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761


    Those are my 2 lower spring perches holesawed out to fit the coilover nuts.

  25. #535
    caibstastic!!1 caibs's Avatar
    Join Date
    Oct 2003
    Location
    perth
    Posts
    228
    shit hey bit of thought went into that man, very well done.

    Sent from my SM-G900I using Tapatalk
    some fucken busted ass peice of shit

  26. #536
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    Going for a run at willowbank tomorrow.
    Car is going good atm. 2 step is sorted track prep should be pretty good because of so much jambo testing lately.

  27. #537
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    10.2 @ 128 1.45 60ft. Best 60ft of 1.42
    We set up the Caltacs when we got there with me in the car, didn't have to touch them the car went dead straight and launched hard all night. It unsetttled a few times when i hit third so had to get off it, thinking i need a decent size water catch can. Did 5 runs 4 of them were 10s.

    Need to get all ihra teched now, add a bit of boost and run a 9.

  28. #538
    Registered User
    Join Date
    Dec 2014
    Location
    Laidley
    Posts
    174
    Great work mate certainly sounded tuff as last night. Sorry for not realizing who I was talking to last night until I saw you getting in your car to race 😂.

  29. #539
    Registered User SR20 KE30's Avatar
    Join Date
    Sep 2012
    Location
    sunshine coast
    Posts
    761
    Thats alright man, i didn't get to watch much did you go well?

  30. #540
    Registered User
    Join Date
    Dec 2014
    Location
    Laidley
    Posts
    174
    Yeah alright ran 12.0 @130 was the best, reaction varied from .015 to .070 so not too bad. Still as inconsistant as ever lol. It'll do for now . A few more pound of boost should push yours into the 9's 👍.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •