Page 17 of 17 FirstFirst ... 71314151617
Results 481 to 495 of 495

Thread: XJ6 - aka purple shitbox, purple people eater, now with more LS1

  1. #481
    "The bitches, are wet" Sketchy's Avatar
    Join Date
    Jan 2002
    Location
    ruddvegas
    Posts
    9,676
    So skids this weekend?
    Quote Originally Posted by Dimi View Post
    80mm of penetration isn't bad, i wish i had that much.
    Quote Originally Posted by schnitzelburger View Post
    My entire working career pretty much consists of suckin dick and takin names.

    Sometimes im too busy to take names.

  2. #482
    two jaaaaaaaags drscrote's Avatar
    Join Date
    Jun 2009
    Location
    Brisbane
    Posts
    656
    Perhaps. Get it started at least.

  3. #483
    two jaaaaaaaags drscrote's Avatar
    Join Date
    Jun 2009
    Location
    Brisbane
    Posts
    656
    It is, by the loosest possible definition, alive again!

    No coolant system yet. Lots of stuff just roughly in position eg rad. Power steering lines and gearbox cooler lines loose and need fixing. Lots of other shit. Think I need to get the electronic speedo out of my old Series 3 dash to take the ECU input, this one is a mechanical drive.

    Great motivator to have it running though.


  4. #484
    Spending money on cars Neeek's Avatar
    Join Date
    Aug 2013
    Location
    Brisbane
    Posts
    815
    Fuck. Yes.

  5. #485
    Registered User I'm DJ!'s Avatar
    Join Date
    Jan 2012
    Location
    Beach-ville
    Posts
    7,995
    Well done sir! So good!!
    DJ's don't need sigs

  6. #486
    two jaaaaaaaags drscrote's Avatar
    Join Date
    Jun 2009
    Location
    Brisbane
    Posts
    656
    Annoying headers leak, and difficulty bleeding the brakes have held things up a bit.

    Brakes should be fine, just pressed for time and fiddly work getting to the bleed nipple near the diff. Have redone the exhaust / header join - too late to test it now.

  7. #487
    "The bitches, are wet" Sketchy's Avatar
    Join Date
    Jan 2002
    Location
    ruddvegas
    Posts
    9,676
    Awesome. Set up a working bee so we can smash this thing together and get it on the blacktop before Christmas.
    Quote Originally Posted by Dimi View Post
    80mm of penetration isn't bad, i wish i had that much.
    Quote Originally Posted by schnitzelburger View Post
    My entire working career pretty much consists of suckin dick and takin names.

    Sometimes im too busy to take names.

  8. #488
    two jaaaaaaaags drscrote's Avatar
    Join Date
    Jun 2009
    Location
    Brisbane
    Posts
    656
    Header leak fixed enough.

    Brakes not bleeding is a faulty master cylinder - only have pressure to front system. Maybe clogged / busted - will pull out today. On plus side just front brakes will make the shed skids easier!

    Cooling system going back. Going to just clamp the rad between the top and bottom plates with rubber 'U' mounts, as per suggestion from jaguarspecialties

    Something like this -


  9. #489
    two jaaaaaaaags drscrote's Avatar
    Join Date
    Jun 2009
    Location
    Brisbane
    Posts
    656
    Master cylinder not looking good.


  10. #490
    Registered User I'm DJ!'s Avatar
    Join Date
    Jan 2012
    Location
    Beach-ville
    Posts
    7,995
    Quote Originally Posted by drscrote View Post
    Master cylinder not looking good.

    Yup. That's seen better days!
    DJ's don't need sigs

  11. #491
    are hairy Dogsballs's Avatar
    Join Date
    Nov 2010
    Location
    melbourne
    Posts
    6,897
    Don't forget bolt in trans cooler line

    Sent from my Nexus 6 using Tapatalk
    Quote Originally Posted by 50RTD View Post
    Dave, have you uploaded the data from the carby?

  12. #492
    Registered User Dean 560 SEC's Avatar
    Join Date
    Jul 2017
    Location
    Perth WA
    Posts
    43
    Thats awesome. Great to hear it running. Keen to get mine going now!
    Current Garage

    1987 Mercedes 560 SEC (Ece)

    2007 BMW E60 530i

    2004 BMW E46 318i

    1982 XJ6 Jaguar 4.2

  13. #493
    Registered User Dean 560 SEC's Avatar
    Join Date
    Jul 2017
    Location
    Perth WA
    Posts
    43
    What front springs are you using? Ive just heard back from the company I was going to order mine from and they now tell me they don't do a lowered LS set only lowered SB. They originally told they they could get them.

    I think the lowered SB springs (-35mm) will sit around standard height with the LS but I'm keen to know how yours sits.
    Current Garage

    1987 Mercedes 560 SEC (Ece)

    2007 BMW E60 530i

    2004 BMW E46 318i

    1982 XJ6 Jaguar 4.2

  14. #494
    two jaaaaaaaags drscrote's Avatar
    Join Date
    Jun 2009
    Location
    Brisbane
    Posts
    656
    I think they are King Springs, lowered chev 350 version.

    Will confirm after the weekend.

  15. #495
    Registered User Dean 560 SEC's Avatar
    Join Date
    Jul 2017
    Location
    Perth WA
    Posts
    43
    cool thanks
    Current Garage

    1987 Mercedes 560 SEC (Ece)

    2007 BMW E60 530i

    2004 BMW E46 318i

    1982 XJ6 Jaguar 4.2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •