Results 1 to 7 of 7

Thread: Cunty 105 Landcruiser wouldn't start

  1. #1
    Opens blackbart's Avatar
    Join Date
    Nov 2001
    Location
    The block brudda
    Posts
    4,093

    Cunty 105 Landcruiser wouldn't start

    Quick one, got an auto 4.5L petrol 105 series Landcruiser. Towing a car trailer yesterday it felt down on power from about 3/4 of the way home. Parked it overnight then went to start it this morning and it cranked fine but wouldn't fire. Tried a few times.

    Get home from work and it starts first go and seems to be normal power.

    I don't want to get stuck somewhere. I'm thinking it's gotta be fuel or spark. Maybe a fuel pump on the way out or an ignition module (if it's got one).

    Any common problems with these?

    Thoughts?
    2001 Suzuki GSX-R 1000
    2002 VX SS
    2004 Nissan El Grand
    2001 Land Cruiser

  2. #2
    Opens blackbart's Avatar
    Join Date
    Nov 2001
    Location
    The block brudda
    Posts
    4,093
    Digging around on the net shows it could be a corroded efi fuse, or a key problem.

  3. #3
    Emissions Friendly VW Sloth's Avatar
    Join Date
    Jan 2013
    Location
    Das Valley
    Posts
    3,013
    on gas? last had plugs?
    Sloth: [Sloff] Noun, like Skompa but with euro shitboxen, a large bearded person, with a penchant for cider and garlic pizza.

    Quote Originally Posted by Rdyno View Post
    That's retardism cunt stop discriminating against me and my fellow retards.

  4. #4
    "The bitches, are wet" Sketchy's Avatar
    Join Date
    Jan 2002
    Location
    ruddvegas
    Posts
    9,901
    Needs a turbo, should sort it out.
    Quote Originally Posted by Dimi View Post
    80mm of penetration isn't bad, i wish i had that much.
    Quote Originally Posted by schnitzelburger View Post
    My entire working career pretty much consists of suckin dick and takin names.

    Sometimes im too busy to take names.

  5. #5
    Opens blackbart's Avatar
    Join Date
    Nov 2001
    Location
    The block brudda
    Posts
    4,093
    No gas. Does need turbo.

    Struggles up hills on the freeway and the air filter light comes on.
    2001 Suzuki GSX-R 1000
    2002 VX SS
    2004 Nissan El Grand
    2001 Land Cruiser

  6. #6
    Opens blackbart's Avatar
    Join Date
    Nov 2001
    Location
    The block brudda
    Posts
    4,093
    Does anyone know if the sub tank pump directly feeds the main line, or does it just pump fuel into the main tank?

  7. #7
    Registered User
    Join Date
    Aug 2014
    Location
    Back of Bondo
    Posts
    42
    Feeds main line.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •