Results 1 to 6 of 6

Thread: Rebuilt SR20 stinks like/burns oil going downhill

  1. #1
    Extended member nopistons's Avatar
    Join Date
    Nov 2013
    Location
    Wollongong
    Posts
    361

    Rebuilt SR20 stinks like/burns oil going downhill

    Hey Braintrust,

    This isn't a crushing issue, moreso just a curiosity.

    What: rebuilt SR20DET. Has done ~ 55,000km. Built engine in mid 2013, used OEM seals/everything, aftermarket cams/valve springs/oversized valves, rods. Have got an oil filter relocaton + cooler (installed between 25k and 30k). Have changed do a hybrid S13/S14 rocker cover with new S14 PCV/breather hoses around the 35-40k mark.

    When: when driving downhill, the car smells oily. When I had ignition issues, it would foul up and need a few good hits before it pumped out some tough smoke/misfired and banged, then would be good again. Since fixing ignition, it'll just make slightly less power for a few seconds.

    No real oil leaks, oil level never drops noticeably. I did a compression test in 2015 or 2016, it was still 150 psi on all 4 cylinders.

    It's done this literally since I put it together. So 4.5 years, 55,000km. The engine internals haven't changed (except changing busted titanium retainers for standard ones at 30k km), but did add the oil coiler / change to S14 PCV / multiple turbo changes over its life time.

    A friend says his friend had a similar problem, every time he's in the car, the culprit being valve stem seals. I would think that would cause more issues at idle? The car idles, drives, and revs out fine.

    I can't remember what I'm saying now

    tldr; car stinks like oil when driving down mountains. seemingly no other symptom or issue. possible causes?

  2. #2
    Registered User
    Join Date
    May 2009
    Location
    windsor nsw
    Posts
    1,197
    If itís stem seals, vac will pull oil past the intake valve guide. So in a long downhill off the throttle, youíll get smoke when you get back in it. If you let it idle for 5 mins and give it a rev youíll get a bushfire on the first rev

  3. #3
    bitch lasagne Bob Vegana.'s Avatar
    Join Date
    Apr 2002
    Location
    Sonova Beach
    Posts
    6,406
    Yeah, definitely sounds like valve stem seals.

    I think Flanders went through this recently too.
    Quote Originally Posted by brewdles View Post
    In short, some cunt at test and tune had a 250cc honda turning to 11ty and it sounded porn. Do that.

  4. #4
    Extended member nopistons's Avatar
    Join Date
    Nov 2013
    Location
    Wollongong
    Posts
    361
    Yeah fair enough. Makes sense to think of downhill driving as time spent in vacuum

    Churs

  5. #5
    Registered User
    Join Date
    Jan 2018
    Location
    blacktown/nsw/Australia
    Posts
    1
    I have ford falcon au1 1998 just wondering how can i reprogramming dash cluster

    Sent from my SM-G900I using Tapatalk

  6. #6
    Pull my finger StupidFlanders's Avatar
    Join Date
    Sep 2010
    Location
    Sydney
    Posts
    1,409
    Yeah mine was way worse when it was on a hill rather than the flat. My shitty exhaust seals had come off altogether on a couple of valves.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •